안드로이드에서 http post 요청을 보낼 시 가장 많이 사용하는 외부 라이브러리 중 하나가 http client 일 듯 합니다.

공식적인 다운로드는 http://hc.apache.org/downloads.cgi 여기서 할 수 있습니다.


그런데 전부 최신버전으로 다운로드 해 놓고서는 빌드해보면 줄기차게 오류를 내뿜습니다...

구글신과 노가다로 3시간정도 헤매고 나서야 답을 찾을 수 있었습니다

라이브러리가 애초에 오류를 품고 있다고 하더군요. 

http mime이라는 라이브러리를 4.3.1 버전으로 다운시켜주면 정상적으로 빌드가 가능합니다.

(참고로 http client 라이브러리와 http mime, http core, apache_mime4j_core 라이브러리를 모두 사용하셔야 http post 요청을 정상적으로 보내실 수 있습니다)


라이브러리 문제로 밤새는 일 없으시길 바라겠습니다^^

'Android' 카테고리의 다른 글

Android httpclinet 관련오류  (0) 2015.10.25

+ Recent posts